# CVE-2024-53864: Cross-site Scripting in a field that is used in the Content name pattern in ibexa/admin-ui

> Attackers with content edit permissions can inject malicious scripts via the Content name pattern field in Ibexa Admin UI, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Nov 2024
- **Updated:** 2 Dec 2024
- **Also known as:** GHSA-8w3p-gf85-qcch

## What is CVE-2024-53864?

CVE-2024-53864 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ibexa Admin UI Bundle is all the necessary parts to run the Ibexa DXP Back Office interface. The Content name pattern is used to build Content names from one or more fields. An XSS vulnerability has been found in this mechanism. Content edit permission is required to exploit it. After the fix, any existing injected XSS will not run. This issue has been patched in version 4.6.14. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-53864?

2 open source packages ship an affected version, including ibexa/admin-ui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ibexa/admin-ui` | Packagist | From 4.6.0 | 4.6.14 |
| `ibexa/admin-ui` | Packagist | From 4.6.0 | 4.6.14 |

## How do I fix CVE-2024-53864?

Upgrade ibexa/admin-ui to 4.6.14 or later.

## Is CVE-2024-53864 being exploited?

There is no known exploitation of CVE-2024-53864 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53864 and fix it if it is affected.

What it is: CVE-2024-53864 is a medium-severity cross-site scripting vulnerability in ibexa admin-ui, published on 29 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-53864 in the wild and no public exploit code.

Affected packages and fixed versions:
- ibexa/admin-ui (Packagist): affected from 4.6.0; fixed in 4.6.14
- ibexa/admin-ui (Packagist): affected from 4.6.0; fixed in 4.6.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53864/ (Markdown: https://insights.sbomify.com/CVE-2024-53864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53864
- OSV: https://osv.dev/vulnerability/CVE-2024-53864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53864/
Summaries are generated and may contain mistakes; the official description above is the record.
