{"answers":{"affected":"2 open source packages ship an affected version, including pnpm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53866 exists.","fix":"Upgrade pnpm to 9.15.0 or later.","what":"CVE-2024-53866 is a medium-severity vulnerability in pnpm, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-53866 and fix it if it is affected.\n\nWhat it is: CVE-2024-53866 is a medium-severity vulnerability in pnpm, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53866 exists.\n\nAffected packages and fixed versions:\n- pnpm (npm): affected all versions; fixed in 9.15.0\n- pnpm (npm): affected all versions; fixed in 9.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53866/ (Markdown: https://insights.sbomify.com/CVE-2024-53866/index.md)","id":"CVE-2024-53866","markdown":"https://insights.sbomify.com/CVE-2024-53866/index.md","name":"CVE-2024-53866","record":{"aliases":["GHSA-vm32-9rqf-rh3r","MINI-3999-f27p-cf9c"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"pnpm package manager","requires_auth":"none","summary":"Attackers can poison the global cache via workspace overrides to execute arbitrary scripts in other workspaces, bypassing ignore-scripts protections.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pnpm","vendor":"pnpm"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other workspaces; and installs by default don't revalidate the data (including on first lockfile generation). This can make workspace A (even running with `ignore-scripts=true`) posion global cache and execute scripts in workspace B. Users generally expect `ignore-scripts` to be sufficient to prevent immediate code execution on install (e.g. when the tree is just repacked/bundled without executing it). Here, that expectation is broken. Global state integrity is lost via operations that one would expect to be secure, enabling subsequently running arbitrary code execution on installs. Version 9.15.0 fixes the issue. As a work-around, use separate cache and store dirs in each workspace.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pnpm vulnerable to no-script global cache poisoning via overrides / `ignore-scripts` evasion","id":"CVE-2024-53866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Synapse Matrix has a partial room state leak via Sliding Sync","id":"CVE-2024-53867"},"packages":[{"ecosystem":"npm","fixed":["9.15.0"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-vm32-9rqf-rh3r"},{"ecosystem":"npm","fixed":["9.15.0"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-vm32-9rqf-rh3r"}],"prev":{"headline":"Python package \"zhmcclient\" has passwords in clear text in its HMC and API logs","id":"CVE-2024-53865"},"products":["pnpm"],"published":"2024-12-10","related":[{"cvss_score":8.8,"headline":"pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement","id":"CVE-2026-50016","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes","id":"CVE-2026-55698","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"pnpm v10+ Bypass \"Dependency lifecycle scripts execution disabled by default\"","id":"CVE-2025-69264","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":8.8,"headline":"Untrusted Search Path in PNPM","id":"CVE-2022-26183","kev_date_added":null,"published":"2022-03-21"},{"cvss_score":8.2,"headline":"pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config","id":"CVE-2026-59195","kev_date_added":null,"published":"2026-07-06"},{"cvss_score":7.6,"headline":"pnpm vulnerable to Command Injection via environment variable substitution","id":"CVE-2025-69262","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":7.5,"headline":"pnpm: manifest identity spoof satisfies allowBuilds and runs attacker lifecycle","id":"CVE-2026-55487","kev_date_added":null,"published":"2026-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-31","vendors":["pnpm"]},"summary":"Attackers can poison the global cache via workspace overrides to execute arbitrary scripts in other workspaces, bypassing ignore-scripts protections.","url":"https://insights.sbomify.com/CVE-2024-53866/"}