# CVE-2024-53867: Synapse Matrix has a partial room state leak via Sliding Sync

> Attackers can leak partial room state changes to users no longer in a room via Sliding Sync in Synapse Matrix homeservers.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-56w4-5538-8v8h, PYSEC-2026-1610

## What is CVE-2024-53867?

CVE-2024-53867 is a medium-severity vulnerability in element-hq synapse, published on 3 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver. The Sliding Sync feature on Synapse versions between 1.113.0rc1 and 1.120.0 can leak partial room state changes to users no longer in a room. Non-state events, like messages, are unaffected. This vulnerability is fixed in 1.120.1.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2024-53867?

3 open source packages ship an affected version, including matrix-synapse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | From 1.113.0rc1 | 1.120.1 |
| `matrix-synapse` | PyPI | From 1.113.0rc1 | 1.120.1 |
| `matrix-synapse` | PyPI | From 1.113.0rc1 | 1.120.1 |

## How do I fix CVE-2024-53867?

Upgrade matrix-synapse to 1.120.1 or later.

## Is CVE-2024-53867 being exploited?

There is no known exploitation of CVE-2024-53867 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53867 and fix it if it is affected.

What it is: CVE-2024-53867 is a medium-severity vulnerability in element-hq synapse, published on 3 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53867 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected from 1.113.0rc1; fixed in 1.120.1
- matrix-synapse (PyPI): affected from 1.113.0rc1; fixed in 1.120.1
- matrix-synapse (PyPI): affected from 1.113.0rc1; fixed in 1.120.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53867/ (Markdown: https://insights.sbomify.com/CVE-2024-53867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53867
- OSV: https://osv.dev/vulnerability/CVE-2024-53867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53867/
Summaries are generated and may contain mistakes; the official description above is the record.
