CVE-2024-53900 Mongoose search injection vulnerability

Critical 9.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-53900?

CVE-2024-53900 is a critical vulnerability in n/a, published on 2 Dec 2024.

Official description

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Weakness: CWE-89

Which versions are affected by CVE-2024-53900?

9 open source packages ship an affected version, including mongoose. It affects 1 product.

PackageAffectedFixed in
mongoose BitnamiAll versions6.13.5, 8.8.3
mongoose npmFrom 3.6.0-rc05.13.23
mongoose npmFrom 3.6.0-rc05.13.23
mongoose npmFrom 6.0.0-rc06.13.5
mongoose npmFrom 6.0.0-rc06.13.5
mongoose npmFrom 7.0.0-rc07.8.3
3 more packages
mongoose npmFrom 7.0.0-rc07.8.3
mongoose npmFrom 8.0.0-rc08.8.3
mongoose npmFrom 8.0.0-rc08.8.3

Products include Mongoosejs Mongoose.

How do I fix CVE-2024-53900?

Upgrade mongoose to a fixed version for your release line: 6.13.5, 8.8.3, 5.13.23 or 7.8.3.

Is CVE-2024-53900 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53900 exists.

Public exploit code: 1 Nuclei template and 2 proofs of concept on GitHub.

Sources

Also known as BIT-mongoose-2024-53900, CLSA-2026-1774916718, GHSA-m7xq-9374-9rvx, ROOT-APP-NPM-CVE-2024-53900.

Is CVE-2024-53900 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free