CVE-2024-53907 Django denial-of-service in django.utils.html.strip_tags()
Attackers can cause denial of service in Django applications by sending inputs with nested incomplete HTML entities to the strip_tags function.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-53907?
CVE-2024-53907 is a high-severity denial of service vulnerability in Djangoproject Django, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Django 5.1 before 5.1.4, 5.0 before 5.0.10, and 4.2 before 4.2.17. The strip_tags() method and striptags template filter are subject to a potential denial-of-service attack via certain inputs containing large sequences of nested incomplete HTML entities.
Weakness: CWE-770
Which versions are affected by CVE-2024-53907?
14 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.17, 5.1.4 |
django PyPI | From 4.2 | 4.2.17 |
django PyPI | From 4.2 | 4.2.17 |
django PyPI | From 4.2.0 | 4.2.17 |
django PyPI | From 5.0 | 5.0.10 |
django PyPI | From 5.0 | 5.0.10 |
8 more packages
django PyPI | From 5.0.0 | 5.0.10 |
django PyPI | From 5.1 | 5.1.4, 5.0.10, 4.2.17 |
django PyPI | From 5.1 | 5.1.4 |
django PyPI | From 5.1 | 5.1.4 |
django PyPI | From 5.1.0 | 5.1.4 |
Django PyPI | From 4.2.0 | 4.2.17 |
Django PyPI | From 5.0.0 | 5.0.10 |
Django PyPI | From 5.1.0 | 5.1.4 |
Linux distribution packages (2)
python-Django SUSE:Package Hub 15 SP5 | All versions | 2.2.28-bp155.7.21.1 |
python-Django openSUSE:Leap 15.5 | All versions | 2.2.28-bp155.7.21.1 |
Products include Djangoproject Django.
How do I fix CVE-2024-53907?
Upgrade django to a fixed version for your release line: 4.2.17, 5.1.4 or 5.0.10.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-53907 being exploited?
There is no known exploitation of CVE-2024-53907 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2024-53907, DEBIAN-CVE-2024-53907, DLA-4006-1, GHSA-8498-2h75-472j, OESA-2024-2542, PYSEC-2024-156 and 3 more.