# CVE-2024-53907: Django denial-of-service in django.utils.html.strip_tags()

> Attackers can cause denial of service in Django applications by sending inputs with nested incomplete HTML entities to the strip_tags function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2024
- **Updated:** 31 Dec 2024
- **Also known as:** BIT-django-2024-53907, DEBIAN-CVE-2024-53907, DLA-4006-1, GHSA-8498-2h75-472j, OESA-2024-2542, PYSEC-2024-156, UBUNTU-CVE-2024-53907, USN-7136-2, openSUSE-SU-2024:0408-1

## What is CVE-2024-53907?

CVE-2024-53907 is a high-severity denial of service vulnerability in Djangoproject Django, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 5.1 before 5.1.4, 5.0 before 5.0.10, and 4.2 before 4.2.17. The strip_tags() method and striptags template filter are subject to a potential denial-of-service attack via certain inputs containing large sequences of nested incomplete HTML entities.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-53907?

14 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.17, 5.1.4 |
| `django` | PyPI | From 4.2 | 4.2.17 |
| `django` | PyPI | From 4.2 | 4.2.17 |
| `django` | PyPI | From 4.2.0 | 4.2.17 |
| `django` | PyPI | From 5.0 | 5.0.10 |
| `django` | PyPI | From 5.0 | 5.0.10 |
| `django` | PyPI | From 5.0.0 | 5.0.10 |
| `django` | PyPI | From 5.1 | 5.1.4, 5.0.10, 4.2.17 |
| `django` | PyPI | From 5.1 | 5.1.4 |
| `django` | PyPI | From 5.1 | 5.1.4 |
| `django` | PyPI | From 5.1.0 | 5.1.4 |
| `Django` | PyPI | From 4.2.0 | 4.2.17 |
| `Django` | PyPI | From 5.0.0 | 5.0.10 |
| `Django` | PyPI | From 5.1.0 | 5.1.4 |
| `python-Django` | SUSE:Package Hub 15 SP5 | All versions | 2.2.28-bp155.7.21.1 |
| `python-Django` | openSUSE:Leap 15.5 | All versions | 2.2.28-bp155.7.21.1 |

Products: Djangoproject Django.

## How do I fix CVE-2024-53907?

Upgrade django to a fixed version for your release line: 4.2.17, 5.1.4 or 5.0.10.

## Is CVE-2024-53907 being exploited?

There is no known exploitation of CVE-2024-53907 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53907 and fix it if it is affected.

What it is: CVE-2024-53907 is a high-severity denial of service vulnerability in Djangoproject Django, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53907 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.17, 5.1.4
- django (PyPI): affected from 4.2; fixed in 4.2.17
- django (PyPI): affected from 4.2; fixed in 4.2.17
- django (PyPI): affected from 4.2.0; fixed in 4.2.17
- django (PyPI): affected from 5.0; fixed in 5.0.10
- django (PyPI): affected from 5.0; fixed in 5.0.10
- django (PyPI): affected from 5.0.0; fixed in 5.0.10
- django (PyPI): affected from 5.1; fixed in 5.1.4, 5.0.10, 4.2.17
- django (PyPI): affected from 5.1; fixed in 5.1.4
- django (PyPI): affected from 5.1; fixed in 5.1.4
- django (PyPI): affected from 5.1.0; fixed in 5.1.4
- Django (PyPI): affected from 4.2.0; fixed in 4.2.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53907/ (Markdown: https://insights.sbomify.com/CVE-2024-53907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53907
- OSV: https://osv.dev/vulnerability/CVE-2024-53907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53907/
Summaries are generated and may contain mistakes; the official description above is the record.
