# CVE-2024-53908: Django SQL injection in HasKey(lhs, rhs) on Oracle

> Attackers can execute SQL injection via HasKey lookup in Django when using Oracle databases with untrusted data, requiring specific database configuration.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2024
- **Updated:** 6 Dec 2024
- **Also known as:** BIT-django-2024-53908, CLSA-2026-1786600187, CLSA-2026-1787718360, DEBIAN-CVE-2024-53908, GHSA-m9g8-fxxm-xg86, MINI-6vvp-rcp6-prhr, PYSEC-2024-157, UBUNTU-CVE-2024-53908

## What is CVE-2024-53908?

CVE-2024-53908 is a critical SQL injection vulnerability in Djangoproject Django, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 5.1 before 5.1.4, 5.0 before 5.0.10, and 4.2 before 4.2.17. Direct usage of the django.db.models.fields.json.HasKey lookup, when an Oracle database is used, is subject to SQL injection if untrusted data is used as an lhs value. (Applications that use the jsonfield.has_key lookup via __ are unaffected.)

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-53908?

14 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.17, 5.1.4 |
| `django` | PyPI | From 4.2 | 4.2.17 |
| `django` | PyPI | From 4.2 | 4.2.17 |
| `django` | PyPI | From 4.2.0 | 4.2.17 |
| `django` | PyPI | From 5.0 | 5.0.10 |
| `django` | PyPI | From 5.0 | 5.0.10 |
| `django` | PyPI | From 5.0.0 | 5.0.10 |
| `django` | PyPI | From 5.1 | 5.1.4, 5.0.10, 4.2.17 |
| `django` | PyPI | From 5.1 | 5.1.4 |
| `django` | PyPI | From 5.1 | 5.1.4 |
| `django` | PyPI | From 5.1.0 | 5.1.4 |
| `Django` | PyPI | From 4.2.0 | 4.2.17 |
| `Django` | PyPI | From 5.0.0 | 5.0.10 |
| `Django` | PyPI | From 5.1.0 | 5.1.4 |

Products: Djangoproject Django.

## How do I fix CVE-2024-53908?

Upgrade django to a fixed version for your release line: 4.2.17, 5.1.4 or 5.0.10.

## Is CVE-2024-53908 being exploited?

There is no known exploitation of CVE-2024-53908 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)
- [CVE-2021-35042](https://insights.sbomify.com/CVE-2021-35042/): SQL Injection in Django (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53908 and fix it if it is affected.

What it is: CVE-2024-53908 is a critical SQL injection vulnerability in Djangoproject Django, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53908 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.17, 5.1.4
- django (PyPI): affected from 4.2; fixed in 4.2.17
- django (PyPI): affected from 4.2; fixed in 4.2.17
- django (PyPI): affected from 4.2.0; fixed in 4.2.17
- django (PyPI): affected from 5.0; fixed in 5.0.10
- django (PyPI): affected from 5.0; fixed in 5.0.10
- django (PyPI): affected from 5.0.0; fixed in 5.0.10
- django (PyPI): affected from 5.1; fixed in 5.1.4, 5.0.10, 4.2.17
- django (PyPI): affected from 5.1; fixed in 5.1.4
- django (PyPI): affected from 5.1; fixed in 5.1.4
- django (PyPI): affected from 5.1.0; fixed in 5.1.4
- Django (PyPI): affected from 4.2.0; fixed in 4.2.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53908/ (Markdown: https://insights.sbomify.com/CVE-2024-53908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53908
- OSV: https://osv.dev/vulnerability/CVE-2024-53908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53908/
Summaries are generated and may contain mistakes; the official description above is the record.
