CVE-2024-53947 Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions

Low 2.3 Published Updated

Attackers can bypass SQL authorization in Apache Superset by using specific unblocked PostgreSQL functions, potentially accessing unauthorized data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-53947?

CVE-2024-53947 is a low-severity SQL injection vulnerability in Apache Superset, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. This issue is a follow-up to CVE-2024-39887 with additional disallowed PostgreSQL functions now included: query_to_xml_and_xmlschema, table_to_xml, table_to_xml_and_xmlschema.

This issue affects Apache Superset: <4.1.0.

Users are recommended to upgrade to version 4.1.0, which fixes the issue or add these Postgres functions to the config set DISALLOWED_SQL_FUNCTIONS.

Weakness: CWE-89

Which versions are affected by CVE-2024-53947?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions4.1.0
apache-superset PyPIAll versions4.1.0
apache-superset PyPIAll versions4.1.0
superset BitnamiAll versions4.1.1

Products include Apache Superset.

How do I fix CVE-2024-53947?

Upgrade apache-superset to 4.1.0 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2024-53947 being exploited?

There is no known exploitation of CVE-2024-53947 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2024-53947, GHSA-92qf-8gh3-gwcm, PYSEC-2026-1165.

Is CVE-2024-53947 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free