CVE-2024-53948 Apache Superset: Error verbosity exposes metadata in analytics databases

Medium 5.3 Published Updated

Attackers can extract sensitive metadata from analytics databases via verbose error messages in Apache Superset.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-53948?

CVE-2024-53948 is a medium-severity vulnerability in Apache Superset, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Generation of Error Message Containing analytics metadata Information in Apache Superset.

This issue affects Apache Superset: before 4.1.0.

Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Weakness: CWE-209

Which versions are affected by CVE-2024-53948?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions4.1.0
apache-superset PyPIAll versions4.1.0
apache-superset PyPIAll versions4.1.0
superset BitnamiAll versions4.1.1

Products include Apache Superset.

How do I fix CVE-2024-53948?

Upgrade apache-superset to 4.1.0 or later.

Is CVE-2024-53948 being exploited?

There is no known exploitation of CVE-2024-53948 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2024-53948, GHSA-2cx9-54hp-r698, PYSEC-2026-1154.

Is CVE-2024-53948 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free