CVE-2024-53949 Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled

High 7.6 Published Updated

Lower privilege users can create roles via API when a specific security feature is enabled, allowing privilege escalation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-53949?

CVE-2024-53949 is a high-severity missing authorization vulnerability in Apache Superset, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.

 issue affects Apache Superset: from 2.0.0 before 4.1.0.

Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2024-53949?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIFrom 2.0.04.1.0
apache-superset PyPIFrom 2.0.04.1.0
apache-superset PyPIFrom 2.0.04.1.0
superset BitnamiFrom 2.0.04.1.1

Products include Apache Superset.

How do I fix CVE-2024-53949?

Upgrade apache-superset to 4.1.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-53949 being exploited?

There is no known exploitation of CVE-2024-53949 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2024-53949, GHSA-35fc-9hrj-3585, PYSEC-2026-1156.

Is CVE-2024-53949 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free