# CVE-2024-53949: Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled

> Lower privilege users can create roles via API when a specific security feature is enabled, allowing privilege escalation.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2024
- **Updated:** 12 Feb 2025
- **Also known as:** BIT-superset-2024-53949, GHSA-35fc-9hrj-3585, PYSEC-2026-1156

## What is CVE-2024-53949?

CVE-2024-53949 is a high-severity missing authorization vulnerability in Apache Superset, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.

 issue affects Apache Superset: from 2.0.0 before 4.1.0.

Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-53949?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | From 2.0.0 | 4.1.0 |
| `apache-superset` | PyPI | From 2.0.0 | 4.1.0 |
| `apache-superset` | PyPI | From 2.0.0 | 4.1.0 |
| `superset` | Bitnami | From 2.0.0 | 4.1.1 |

Products: Apache Superset.

## How do I fix CVE-2024-53949?

Upgrade apache-superset to 4.1.0 or later.

## Is CVE-2024-53949 being exploited?

There is no known exploitation of CVE-2024-53949 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53949 and fix it if it is affected.

What it is: CVE-2024-53949 is a high-severity missing authorization vulnerability in Apache Superset, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-53949 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected from 2.0.0; fixed in 4.1.0
- apache-superset (PyPI): affected from 2.0.0; fixed in 4.1.0
- apache-superset (PyPI): affected from 2.0.0; fixed in 4.1.0
- superset (Bitnami): affected from 2.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53949/ (Markdown: https://insights.sbomify.com/CVE-2024-53949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53949
- OSV: https://osv.dev/vulnerability/CVE-2024-53949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53949/
Summaries are generated and may contain mistakes; the official description above is the record.
