{"answers":{"affected":"2 open source packages ship an affected version, including rails-html-sanitizer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-53988 in the wild and no public exploit code.","fix":"Upgrade rails-html-sanitizer to 1.6.1 or later.","what":"CVE-2024-53988 is a low-severity cross-site scripting vulnerability in rails-html-sanitizer, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-53988 and fix it if it is affected.\n\nWhat it is: CVE-2024-53988 is a low-severity cross-site scripting vulnerability in rails-html-sanitizer, published on 2 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-53988 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails-html-sanitizer (RubyGems): affected from 1.6.0; fixed in 1.6.1\n- rails-html-sanitizer (RubyGems): affected from 1.6.0; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-53988/ (Markdown: https://insights.sbomify.com/CVE-2024-53988/index.md)","id":"CVE-2024-53988","markdown":"https://insights.sbomify.com/CVE-2024-53988/index.md","name":"CVE-2024-53988","record":{"aliases":["GHSA-cfjx-w229-hgx5","UBUNTU-CVE-2024-53988"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby HTML sanitizer","requires_auth":"none","summary":"Attackers can inject malicious scripts via specific HTML tags in Rails applications using the rails-html-sanitizer library with non-default configurations.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rails_html_sanitizers","vendor":"rubyonrails"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails \u003e= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags where the \"math\", \"mtext\", \"table\", and \"style\" elements are allowed and either either \"mglyph\" or \"malignmark\" are allowed. This vulnerability is fixed in 1.6.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0","id":"CVE-2024-53988","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0","id":"CVE-2024-53989"},"packages":[{"ecosystem":"RubyGems","fixed":["1.6.1"],"introduced":["1.6.0"],"last_affected":[],"package":"rails-html-sanitizer","purl":null,"source":"GHSA-cfjx-w229-hgx5"},{"ecosystem":"RubyGems","fixed":["1.6.1"],"introduced":["1.6.0"],"last_affected":[],"package":"rails-html-sanitizer","purl":"pkg:gem/rails-html-sanitizer","source":"GHSA-cfjx-w229-hgx5"}],"prev":{"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0","id":"CVE-2024-53987"},"products":["rails-html-sanitizer"],"published":"2024-12-02","related":[{"cvss_score":2.3,"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0","id":"CVE-2024-53985","kev_date_added":null,"published":"2024-12-02"},{"cvss_score":2.3,"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0","id":"CVE-2024-53986","kev_date_added":null,"published":"2024-12-02"},{"cvss_score":2.3,"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0","id":"CVE-2024-53987","kev_date_added":null,"published":"2024-12-02"},{"cvss_score":2.3,"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0","id":"CVE-2024-53989","kev_date_added":null,"published":"2024-12-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-03","vendors":["rails"]},"summary":"Attackers can inject malicious scripts via specific HTML tags in Rails applications using the rails-html-sanitizer library with non-default configurations.","url":"https://insights.sbomify.com/CVE-2024-53988/"}