# CVE-2024-53991: Potential Backup file leaked via Nginx in Discourse

> Attackers can leak local backup files via Nginx if local storage is enabled, exposing sensitive data; upgrade Discourse or move backups to S3.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2024
- **Updated:** 20 Dec 2024
- **Also known as:** BIT-discourse-2024-53991, GHSA-567m-82f6-56rv

## What is CVE-2024-53991?

CVE-2024-53991 is a high-severity vulnerability in Discourse Discourse, published on 19 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source platform for community discussion. This vulnerability only impacts Discourse instances configured to use `FileStore::LocalStore` which means uploads and backups are stored locally on disk. If an attacker knows the name of the Discourse backup file, the attacker can trick nginx into sending the Discourse backup file with a well crafted request. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. Users unable to upgrade can either 1. Download all local backups on to another storage device, disable the `enable_backups` site setting and delete all backups until the site has been upgraded to pull in the fix. Or  2. Change the `backup_location` site setting to `s3` so that backups are stored and downloaded directly from S3.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-53991?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.3.3 |

Products: Discourse Discourse.

## How do I fix CVE-2024-53991?

Upgrade discourse to 3.3.3 or later.

## Is CVE-2024-53991 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53991 exists.

Public exploit code:

- Discourse Backup File Disclosure Via Default Nginx Configuration (nuclei): http/cves/2024/CVE-2024-53991.yaml

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53991 and fix it if it is affected.

What it is: CVE-2024-53991 is a high-severity vulnerability in Discourse Discourse, published on 19 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53991 exists.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53991/ (Markdown: https://insights.sbomify.com/CVE-2024-53991/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53991
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53991
- OSV: https://osv.dev/vulnerability/CVE-2024-53991

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53991/
Summaries are generated and may contain mistakes; the official description above is the record.
