# CVE-2024-53999: Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality

> Attackers can inject malicious scripts via filenames that execute when users view file comparisons, potentially compromising user sessions.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Dec 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-5jc6-h9w7-jm3p, PYSEC-2026-1666

## What is CVE-2024-53999?

CVE-2024-53999 is a high-severity cross-site scripting vulnerability in Mobile-Security-Framework-MobSF, published on 3 Dec 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Mobile Security Framework (MobSF) is a pen-testing, malware analysis and security assessment framework capable of performing static and dynamic analysis. The application allows users to upload files with scripts in the filename parameter. As a result, a malicious user can upload a script file to the system. When users in the application use the "Diff or Compare" functionality, they are affected by a Stored Cross-Site Scripting vulnerability. This vulnerability is fixed in 4.2.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-53999?

3 open source packages ship an affected version, including mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 4.2.9 |
| `mobsf` | PyPI | All versions | 4.2.9 |
| `mobsf` | PyPI | All versions | 4.2.9 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2024-53999?

Upgrade mobsf to 4.2.9 or later.

## Is CVE-2024-53999 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53999 exists.

## Other vulnerabilities in Mobile-Security-Framework-MobSF

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2025-24803](https://insights.sbomify.com/CVE-2025-24803/): Stored Cross-Site Scripting (XSS) in MobSF (high 8.4)
- [CVE-2026-24490](https://insights.sbomify.com/CVE-2026-24490/): MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field (high 8.1)
- [CVE-2024-43399](https://insights.sbomify.com/CVE-2024-43399/): Mobile Security Framework (MobSF) has a Zip Slip Vulnerability in .a Static Library Files (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-53999 and fix it if it is affected.

What it is: CVE-2024-53999 is a high-severity cross-site scripting vulnerability in Mobile-Security-Framework-MobSF, published on 3 Dec 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-53999 exists.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 4.2.9
- mobsf (PyPI): affected all versions; fixed in 4.2.9
- mobsf (PyPI): affected all versions; fixed in 4.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-53999/ (Markdown: https://insights.sbomify.com/CVE-2024-53999/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-53999
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-53999
- OSV: https://osv.dev/vulnerability/CVE-2024-53999

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-53999/
Summaries are generated and may contain mistakes; the official description above is the record.
