# CVE-2024-54001: Kanboard allows a persistent HTML injection site scripting in settings page date format

> Attackers can inject persistent HTML or JavaScript into Kanboard settings, potentially leading to XSS and account takeover if CSP is bypassed.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Dec 2024
- **Updated:** 5 Dec 2024
- **Also known as:** GHSA-4vvp-jf72-chrj

## What is CVE-2024-54001?

CVE-2024-54001 is a medium-severity cross-site scripting vulnerability in kanboard, published on 5 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kanboard is project management software that focuses on the Kanban methodology. HTML can be injected and stored into the application settings section. The fields application_language, application_date_format,application_timezone and application_time_format allow arbirary user input which is reflected. The vulnerability can become xss if the user input is javascript code that bypass CSP. This vulnerability is fixed in 1.2.41.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2024-54001?

It affects 1 product.


Products: Kanboard Kanboard.

## How do I fix CVE-2024-54001?

No fix has been published for CVE-2024-54001 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-54001 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54001 exists.

## Other vulnerabilities in kanboard

- [CVE-2026-21881](https://insights.sbomify.com/CVE-2026-21881/): Kanboard is Vulnerable to Reverse Proxy Authentication Bypass (critical 9.1)
- [CVE-2025-55010](https://insights.sbomify.com/CVE-2025-55010/): Kanboard Authenticated Admin Remote Code Execution via Unsafe Deserialization of Events (critical 9.1)
- [CVE-2024-51747](https://insights.sbomify.com/CVE-2024-51747/): Arbitrary File Read and Delete in kanboard (critical 9.1)
- [CVE-2024-51748](https://insights.sbomify.com/CVE-2024-51748/): Remote code execution through language setting in kanboard (critical 9.1)
- [CVE-2017-12850](https://insights.sbomify.com/CVE-2017-12850/): Business logic in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54001 and fix it if it is affected.

What it is: CVE-2024-54001 is a medium-severity cross-site scripting vulnerability in kanboard, published on 5 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54001 exists.

Affected product: kanboard. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54001/ (Markdown: https://insights.sbomify.com/CVE-2024-54001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54001
- OSV: https://osv.dev/vulnerability/CVE-2024-54001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54001/
Summaries are generated and may contain mistakes; the official description above is the record.
