CVE-2024-54016 compression bomb attack in Apache Seata Server
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2024-54016?
CVE-2024-54016 is a medium-severity vulnerability in Apache Seata (incubating), published on 20 Mar 2025.
Official description
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating).
This issue affects Apache Seata (incubating): through <=2.2.0.
Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Weakness: CWE-409
Which versions are affected by CVE-2024-54016?
2 open source packages ship an affected version, including org.apache.seata:seata-parent. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.seata:seata-parent Maven | From 2.0.0 | 2.3.0 |
org.apache.seata:seata-parent Maven | From 2.0.0 | 2.3.0 |
Products include Apache Seata.
How do I fix CVE-2024-54016?
Upgrade org.apache.seata:seata-parent to 2.3.0 or later.
Is CVE-2024-54016 being exploited?
There is no known exploitation of CVE-2024-54016 in the wild and no public exploit code.
Other vulnerabilities in Apache Seata (incubating)
- CVE-2025-53606 Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server
- CVE-2025-32897 Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server
- CVE-2024-47552 Apache Seata (incubating): Deserialization of untrusted Data in jraft mode in Apache Seata Server
- CVE-2024-22399 Apache Seata: Remote Code Execution vulnerability via Hessian Deserialization in Apache Seata Server
Sources
Also known as GHSA-65vg-64g8-mwjr.