# CVE-2024-54016: compression bomb attack in Apache Seata Server


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-65vg-64g8-mwjr

## What is CVE-2024-54016?

CVE-2024-54016 is a medium-severity vulnerability in Apache Seata (incubating), published on 20 Mar 2025. 

### Official description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating).

This issue affects Apache Seata (incubating): through <=2.2.0.

Users are recommended to upgrade to version 2.3.0, which fixes the issue.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2024-54016?

2 open source packages ship an affected version, including org.apache.seata:seata-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.seata:seata-parent` | Maven | From 2.0.0 | 2.3.0 |
| `org.apache.seata:seata-parent` | Maven | From 2.0.0 | 2.3.0 |

Products: Apache Seata.

## How do I fix CVE-2024-54016?

Upgrade org.apache.seata:seata-parent to 2.3.0 or later.

## Is CVE-2024-54016 being exploited?

There is no known exploitation of CVE-2024-54016 in the wild and no public exploit code.

## Other vulnerabilities in Apache Seata (incubating)

- [CVE-2025-53606](https://insights.sbomify.com/CVE-2025-53606/): Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server (critical 9.8)
- [CVE-2025-32897](https://insights.sbomify.com/CVE-2025-32897/): Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server (critical 9.8)
- [CVE-2024-47552](https://insights.sbomify.com/CVE-2024-47552/): Apache Seata (incubating): Deserialization of untrusted Data in jraft mode in Apache Seata Server (critical 9.8)
- [CVE-2024-22399](https://insights.sbomify.com/CVE-2024-22399/): Apache Seata: Remote Code Execution vulnerability via Hessian Deserialization in Apache Seata Server (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54016 and fix it if it is affected.

What it is: CVE-2024-54016 is a medium-severity vulnerability in Apache Seata (incubating), published on 20 Mar 2025. 
Exploitation: There is no known exploitation of CVE-2024-54016 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.seata:seata-parent (Maven): affected from 2.0.0; fixed in 2.3.0
- org.apache.seata:seata-parent (Maven): affected from 2.0.0; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54016/ (Markdown: https://insights.sbomify.com/CVE-2024-54016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54016
- OSV: https://osv.dev/vulnerability/CVE-2024-54016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54016/
Summaries are generated and may contain mistakes; the official description above is the record.
