CVE-2024-54083 DoS via lack of type validation in Calls
An attacker can cause a client-side denial of service for users in specific channels by sending a specially crafted post with invalid call properties.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-54083?
CVE-2024-54083 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to properly validate the type of callProps which allows a user to cause a client side (webapp and mobile) DoS to users of particular channels, by sending a specially crafted post.
Weakness: CWE-1287
Which versions are affected by CVE-2024-54083?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0 | 10.0.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0 | 10.0.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.1.0 | 10.1.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.1.0 | 10.1.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.5 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.5 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.13 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.13 |
github.com/mattermost/mattermost-server Go | From 9.5.0+incompatible | 9.5.13+incompatible, 9.11.5+incompatible, 10.0.3+incompatible, 10.1.3+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-54083?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.0.3, 10.1.3, 9.11.5 or 9.5.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-54083 being exploited?
There is no known exploitation of CVE-2024-54083 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-69pr-78gv-7c6h, GO-2024-3337.