# CVE-2024-54083: DoS via lack of type validation in Calls

> An attacker can cause a client-side denial of service for users in specific channels by sending a specially crafted post with invalid call properties.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2024
- **Updated:** 16 Dec 2024
- **Also known as:** GHSA-69pr-78gv-7c6h, GO-2024-3337

## What is CVE-2024-54083?

CVE-2024-54083 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to properly validate the type of callProps which allows a user to cause a client side (webapp and mobile) DoS to users of particular channels, by sending a specially crafted post.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2024-54083?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.0.0 | 10.0.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.0.0 | 10.0.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.1.0 | 10.1.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.1.0 | 10.1.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | 9.11.5 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | 9.11.5 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.13 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.13 |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0+incompatible | 9.5.13+incompatible, 9.11.5+incompatible, 10.0.3+incompatible, 10.1.3+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-54083?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.0.3, 10.1.3, 9.11.5 or 9.5.13.

## Is CVE-2024-54083 being exploited?

There is no known exploitation of CVE-2024-54083 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54083 and fix it if it is affected.

What it is: CVE-2024-54083 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-54083 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.0.0; fixed in 10.0.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.0.0; fixed in 10.0.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.1.0; fixed in 10.1.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.1.0; fixed in 10.1.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; fixed in 9.11.5
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; fixed in 9.11.5
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.13
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.13
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0+incompatible; fixed in 9.5.13+incompatible, 9.11.5+incompatible, 10.0.3+incompatible, 10.1.3+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54083/ (Markdown: https://insights.sbomify.com/CVE-2024-54083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54083
- OSV: https://osv.dev/vulnerability/CVE-2024-54083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54083/
Summaries are generated and may contain mistakes; the official description above is the record.
