CVE-2024-54141 phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available
An attacker can obtain database credentials when the database server is unavailable, exposing sensitive information in error messages.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-54141?
CVE-2024-54141 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Prior to 4.0.0, phpMyFAQ exposes the database (ie postgreSQL) server's credential when connection to DB fails. This vulnerability is fixed in 4.0.0.
Weakness: CWE-209
Which versions are affected by CVE-2024-54141?
2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
thorsten/phpmyfaq Packagist | All versions | 4.0.0 |
thorsten/phpmyfaq Packagist | All versions | 4.0.0 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2024-54141?
Upgrade thorsten/phpmyfaq to 4.0.0 or later.
Is CVE-2024-54141 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54141 exists.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-vrjr-p3xp-xx2x.