{"answers":{"affected":"2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54141 exists.","fix":"Upgrade thorsten/phpmyfaq to 4.0.0 or later.","what":"CVE-2024-54141 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-54141 and fix it if it is affected.\n\nWhat it is: CVE-2024-54141 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54141 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.0\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-54141/ (Markdown: https://insights.sbomify.com/CVE-2024-54141/index.md)","id":"CVE-2024-54141","markdown":"https://insights.sbomify.com/CVE-2024-54141/index.md","name":"CVE-2024-54141","record":{"aliases":["GHSA-vrjr-p3xp-xx2x"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ web application","requires_auth":"none","summary":"An attacker can obtain database credentials when the database server is unavailable, exposing sensitive information in error messages.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Prior to 4.0.0, phpMyFAQ exposes the database (ie postgreSQL) server's credential when connection to DB fails. This vulnerability is fixed in 4.0.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available","id":"CVE-2024-54141","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting via Discourse-ai SharedAiConversation onebox in Discourse","id":"CVE-2024-54142"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-vrjr-p3xp-xx2x"},{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-vrjr-p3xp-xx2x"}],"prev":{"headline":"sigstore-java has a vulnerability with bundle verification","id":"CVE-2024-54140"},"products":["phpMyFAQ"],"published":"2024-12-06","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-06","vendors":["thorsten"]},"summary":"An attacker can obtain database credentials when the database server is unavailable, exposing sensitive information in error messages.","url":"https://insights.sbomify.com/CVE-2024-54141/"}