# CVE-2024-54141: phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available

> An attacker can obtain database credentials when the database server is unavailable, exposing sensitive information in error messages.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2024
- **Updated:** 6 Dec 2024
- **Also known as:** GHSA-vrjr-p3xp-xx2x

## What is CVE-2024-54141?

CVE-2024-54141 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Prior to 4.0.0, phpMyFAQ exposes the database (ie postgreSQL) server's credential when connection to DB fails. This vulnerability is fixed in 4.0.0.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2024-54141?

2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.0 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.0.0 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2024-54141?

Upgrade thorsten/phpmyfaq to 4.0.0 or later.

## Is CVE-2024-54141 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54141 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54141 and fix it if it is affected.

What it is: CVE-2024-54141 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 6 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54141 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.0
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54141/ (Markdown: https://insights.sbomify.com/CVE-2024-54141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54141
- OSV: https://osv.dev/vulnerability/CVE-2024-54141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54141/
Summaries are generated and may contain mistakes; the official description above is the record.
