# CVE-2024-54148: Gogs has a Path Traversal in file editing UI

> A malicious user can exploit a path traversal vulnerability in the file editing UI to gain SSH access to the server.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2024
- **Updated:** 24 Dec 2024
- **Also known as:** GHSA-r7j8-5h9c-f6fx, GO-2024-3355

## What is CVE-2024-54148?

CVE-2024-54148 is a high-severity path traversal vulnerability in gogs, published on 23 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. A malicious user is able to commit and edit a crafted symlink file to a repository to gain SSH access to the server. The vulnerability is fixed in 0.13.1.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-54148?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | 0.13.1 |
| `gogs.io/gogs` | Go | All versions | 0.13.1 |
| `gogs.io/gogs` | Go | All versions | 0.13.1 |

Products: Gogs Gogs.

## How do I fix CVE-2024-54148?

Upgrade gogs.io/gogs to 0.13.1 or later.

## Is CVE-2024-54148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54148 exists.

## Other vulnerabilities in gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54148 and fix it if it is affected.

What it is: CVE-2024-54148 is a high-severity path traversal vulnerability in gogs, published on 23 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-54148 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.1
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.1
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54148/ (Markdown: https://insights.sbomify.com/CVE-2024-54148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54148
- OSV: https://osv.dev/vulnerability/CVE-2024-54148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54148/
Summaries are generated and may contain mistakes; the official description above is the record.
