{"answers":{"affected":"2 open source packages ship an affected version, including angular-expressions.","exploited":"There is no known exploitation of CVE-2024-54152 in the wild and no public exploit code.","fix":"Upgrade angular-expressions to 1.4.3 or later.","what":"CVE-2024-54152 is a critical code injection vulnerability in peerigon angular-expressions, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-54152 and fix it if it is affected.\n\nWhat it is: CVE-2024-54152 is a critical code injection vulnerability in peerigon angular-expressions, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-54152 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- angular-expressions (npm): affected all versions; fixed in 1.4.3\n- angular-expressions (npm): affected all versions; fixed in 1.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-54152/ (Markdown: https://insights.sbomify.com/CVE-2024-54152/index.md)","id":"CVE-2024-54152","markdown":"https://insights.sbomify.com/CVE-2024-54152/index.md","name":"CVE-2024-54152","record":{"aliases":["GHSA-5462-4vcx-jh7j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Angular expressions library","requires_auth":"none","summary":"An attacker can execute arbitrary code on the system by injecting malicious expressions into the Angular Expressions library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to version 1.4.3, an attacker can write a malicious expression that escapes the sandbox to execute arbitrary code on the system. With a more complex (undisclosed) payload, one can get full access to Arbitrary code execution on the system. The problem has been patched in version 1.4.3 of Angular Expressions. Two possible workarounds are available. One may either disable access to `__proto__` globally or make sure that one uses the function with just one argument.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2024-12-30","github_poc":1,"max_poc_stars":12,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-12-30T01:07:48Z","kind":"github_poc","ref":"https://github.com/math-x-io/CVE-2024-54152","stars":12,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Angular Expressions - Remote Code Execution when using locals","id":"CVE-2024-54152","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in YouTrack","id":"CVE-2024-54153"},"packages":[{"ecosystem":"npm","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"angular-expressions","purl":null,"source":"GHSA-5462-4vcx-jh7j"},{"ecosystem":"npm","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"angular-expressions","purl":"pkg:npm/angular-expressions","source":"GHSA-5462-4vcx-jh7j"}],"prev":{"headline":"Directus allows unauthenticated access to WebSocket events and operations","id":"CVE-2024-54151"},"products":["angular-expressions"],"published":"2024-12-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-12-10","vendors":["peerigon"]},"summary":"An attacker can execute arbitrary code on the system by injecting malicious expressions into the Angular Expressions library.","url":"https://insights.sbomify.com/CVE-2024-54152/"}