# CVE-2024-54152: Angular Expressions - Remote Code Execution when using locals

> An attacker can execute arbitrary code on the system by injecting malicious expressions into the Angular Expressions library.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2024
- **Updated:** 10 Dec 2024
- **Also known as:** GHSA-5462-4vcx-jh7j

## What is CVE-2024-54152?

CVE-2024-54152 is a critical code injection vulnerability in peerigon angular-expressions, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to version 1.4.3, an attacker can write a malicious expression that escapes the sandbox to execute arbitrary code on the system. With a more complex (undisclosed) payload, one can get full access to Arbitrary code execution on the system. The problem has been patched in version 1.4.3 of Angular Expressions. Two possible workarounds are available. One may either disable access to `__proto__` globally or make sure that one uses the function with just one argument.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-54152?

2 open source packages ship an affected version, including angular-expressions.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `angular-expressions` | npm | All versions | 1.4.3 |
| `angular-expressions` | npm | All versions | 1.4.3 |

## How do I fix CVE-2024-54152?

Upgrade angular-expressions to 1.4.3 or later.

## Is CVE-2024-54152 being exploited?

There is no known exploitation of CVE-2024-54152 in the wild and no public exploit code.

Public exploit code:

- https://github.com/math-x-io/CVE-2024-54152 (github_poc): https://github.com/math-x-io/CVE-2024-54152

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54152 and fix it if it is affected.

What it is: CVE-2024-54152 is a critical code injection vulnerability in peerigon angular-expressions, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-54152 in the wild and no public exploit code.

Affected packages and fixed versions:
- angular-expressions (npm): affected all versions; fixed in 1.4.3
- angular-expressions (npm): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54152/ (Markdown: https://insights.sbomify.com/CVE-2024-54152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54152
- OSV: https://osv.dev/vulnerability/CVE-2024-54152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54152/
Summaries are generated and may contain mistakes; the official description above is the record.
