CVE-2024-5416 Cross-site scripting in Elementor Website Builder – more than just a page builder
Authenticated contributors can inject arbitrary scripts via URL parameters in Elementor widgets, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2024-5416?
CVE-2024-5416 is a medium-severity cross-site scripting vulnerability in elemntor Elementor Website Builder – more than just a page builder, published on 11 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the url parameter of multiple widgets in all versions up to, and including, 3.23.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in Elementor Editor pages. This was partially patched in version 3.23.2.
Weakness: CWE-79
Which versions are affected by CVE-2024-5416?
It affects 1 product.
Products include Elementor Website Builder.
How do I fix CVE-2024-5416?
No fix has been published for CVE-2024-5416 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-5416 being exploited?
There is no known exploitation of CVE-2024-5416 in the wild and no public exploit code.
Other vulnerabilities in elemntor Elementor Website Builder – more than just a page builder
- CVE-2023-48777 WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability
- CVE-2020-7109 Cross-site scripting in n/a
- CVE-2022-1329 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution
- CVE-2024-24934 WordPress Elementor plugin <= 3.19.0 - Arbitrary File Deletion and Phar Deserialization vulnerability
- CVE-2023-0329 Elementor Website Builder < 3.12.2 - Admin+ SQLi
Sources
Also known as GHSA-8hhj-q97q-8vh4.