{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-5416 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-5416 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-5416 is a medium-severity cross-site scripting vulnerability in elemntor Elementor Website Builder – more than just a page builder, published on 11 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-5416 and fix it if it is affected.\n\nWhat it is: CVE-2024-5416 is a medium-severity cross-site scripting vulnerability in elemntor Elementor Website Builder – more than just a page builder, published on 11 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-5416 in the wild and no public exploit code.\n\nAffected product: elemntor Elementor Website Builder – more than just a page builder. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5416/ (Markdown: https://insights.sbomify.com/CVE-2024-5416/index.md)","id":"CVE-2024-5416","markdown":"https://insights.sbomify.com/CVE-2024-5416/index.md","name":"CVE-2024-5416","record":{"aliases":["GHSA-8hhj-q97q-8vh4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated contributors can inject arbitrary scripts via URL parameters in Elementor widgets, potentially leading to code execution or account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"website_builder","vendor":"elementor"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the url parameter of multiple widgets in all versions up to, and including, 3.23.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in Elementor Editor pages. This was partially patched in version 3.23.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in Elementor Website Builder – more than just a page builder","id":"CVE-2024-5416","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":7,"next":{"headline":"Gutentor \u003c 3.3.6 - Contributor+ Stored XSS","id":"CVE-2024-5417"},"packages":[],"prev":{"headline":"Cross-Site Scripting (XSS) vulnerability on PhpMyBackupPro","id":"CVE-2024-5415"},"products":["Elementor Website Builder – more than just a page builder"],"published":"2024-09-11","related":[{"cvss_score":9.9,"headline":"WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability","id":"CVE-2023-48777","kev_date_added":null,"published":"2024-03-26"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2020-7109","kev_date_added":null,"published":"2020-01-22"},{"cvss_score":8.8,"headline":"Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution","id":"CVE-2022-1329","kev_date_added":null,"published":"2022-04-19"},{"cvss_score":8.5,"headline":"WordPress Elementor plugin \u003c= 3.19.0 - Arbitrary File Deletion and Phar Deserialization vulnerability","id":"CVE-2024-24934","kev_date_added":null,"published":"2024-05-17"},{"cvss_score":7.2,"headline":"Elementor Website Builder \u003c 3.12.2 - Admin+ SQLi","id":"CVE-2023-0329","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":6.5,"headline":"WordPress Elementor plugin \u003c= 3.25.10 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-54444","kev_date_added":null,"published":"2025-02-25"},{"cvss_score":6.5,"headline":"WordPress Elementor plugin \u003c= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability","id":"CVE-2023-47504","kev_date_added":null,"published":"2024-04-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["elemntor"]},"summary":"Authenticated contributors can inject arbitrary scripts via URL parameters in Elementor widgets, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2024-5416/"}