CVE-2024-5423 Uncontrolled Resource Consumption in GitLab

Medium 6.5 Published Updated

An attacker can cause resource exhaustion and denial of service in GitLab via the banzai pipeline, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-5423?

CVE-2024-5423 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 8 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Multiple Denial of Service (DoS) conditions has been discovered in GitLab CE/EE affecting all versions starting from 1.0 prior to 17.0.6, starting from 17.1 prior to 17.1.4, and starting from 17.2 prior to 17.2.2 which allowed an attacker to cause resource exhaustion via banzai pipeline.

Weakness: CWE-400

Which versions are affected by CVE-2024-5423?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 1.0.017.0.6, 17.1.4, 17.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-5423?

Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-5423 being exploited?

There is no known exploitation of CVE-2024-5423 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-5423, GHSA-q28r-ggr6-763f, UBUNTU-CVE-2024-5423.

Is CVE-2024-5423 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free