# CVE-2024-54266: WordPress ImageRecycle pdf & image compression plugin <= 3.1.16 - Reflected Cross Site Scripting (XSS) vulnerability

> Attackers can inject malicious scripts via reflected XSS in the ImageRecycle WordPress plugin, potentially compromising user sessions.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Dec 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-23hv-h2r7-ggj5

## What is CVE-2024-54266?

CVE-2024-54266 is a high-severity cross-site scripting vulnerability in ImageRecycle pdf & image compression, published on 13 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ImageRecycle ImageRecycle pdf & image compression imagerecycle-pdf-image-compression allows Reflected XSS.This issue affects ImageRecycle pdf & image compression: from n/a through <= 3.1.16.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-54266?

It affects 1 product.


Products: Imagerecycle Imagerecycle Pdf \& Image Compression.

## How do I fix CVE-2024-54266?

No fix has been published for CVE-2024-54266 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-54266 being exploited?

There is no known exploitation of CVE-2024-54266 in the wild and no public exploit code.

## Other vulnerabilities in ImageRecycle pdf & image compression

- [CVE-2023-30494](https://insights.sbomify.com/CVE-2023-30494/): WordPress ImageRecycle pdf & image compression Plugin <= 3.1.10 is vulnerable to Cross Site Scripting (XSS) (high 7.1)
- [CVE-2023-40196](https://insights.sbomify.com/CVE-2023-40196/): WordPress ImageRecycle pdf & image compression Plugin <= 3.1.11 is vulnerable to Cross Site Scripting (XSS) (high 7.1)
- [CVE-2024-6631](https://insights.sbomify.com/CVE-2024-6631/): ImageRecycle pdf & image compression <= 3.1.14 - Missing Authorization in Several AJAX Actions (medium 5.0)
- [CVE-2024-8120](https://insights.sbomify.com/CVE-2024-8120/): ImageRecycle pdf & image compression <= 3.1.14 - Cross-Site Request in Several AJAX Actions (medium 4.7)
- [CVE-2024-0983](https://insights.sbomify.com/CVE-2024-0983/): ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Settings Update in enableOptimization (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54266 and fix it if it is affected.

What it is: CVE-2024-54266 is a high-severity cross-site scripting vulnerability in ImageRecycle pdf & image compression, published on 13 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-54266 in the wild and no public exploit code.

Affected product: ImageRecycle pdf & image compression. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54266/ (Markdown: https://insights.sbomify.com/CVE-2024-54266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54266
- OSV: https://osv.dev/vulnerability/CVE-2024-54266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54266/
Summaries are generated and may contain mistakes; the official description above is the record.
