CVE-2024-5430 Improper Access Control in GitLab
A project maintainer can improperly delete merge request approval policies via GraphQL, bypassing intended access controls.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-5430?
CVE-2024-5430 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.10 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, which allows a project maintainer can delete the merge request approval policy via graphQL.
Weakness: CWE-284
Which versions are affected by CVE-2024-5430?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.10.0 | 16.11.5, 17.0.3, 17.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-5430?
Upgrade gitlab to a fixed version for your release line: 16.11.5, 17.0.3 or 17.1.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-5430 being exploited?
There is no known exploitation of CVE-2024-5430 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-5430, GHSA-w9qv-xhc6-m43c, UBUNTU-CVE-2024-5430.