CVE-2024-5435 Generation of Error Message Containing Sensitive Information in GitLab
An attacker with repository mirror configuration access can disclose user passwords via error messages in GitLab.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-5435?
CVE-2024-5435 is a medium-severity vulnerability in Gitlab Gitlab, published on 12 Sep 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
An issue has been discovered discovered in GitLab EE/CE affecting all versions starting from 15.10 before 17.1.7, all versions starting from 17.2 before 17.2.5, all versions starting from 17.3 before 17.3.2 will disclose user password from repository mirror configuration.
Weakness: CWE-209
Which versions are affected by CVE-2024-5435?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.10.0 | 17.1.7, 17.2.5, 17.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-5435?
Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.
Is CVE-2024-5435 being exploited?
There is no known exploitation of CVE-2024-5435 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-5435, GHSA-mc42-9p8q-pxff, UBUNTU-CVE-2024-5435.