{"answers":{"affected":"3 open source packages ship an affected version, including lollms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5443 exists.","fix":"Upgrade lollms to 9.5.1 or later.","what":"CVE-2024-5443 is a critical path traversal vulnerability in parisneo/lollms, published on 22 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-5443 and fix it if it is affected.\n\nWhat it is: CVE-2024-5443 is a critical path traversal vulnerability in parisneo/lollms, published on 22 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5443 exists.\n\nAffected packages and fixed versions:\n- lollms (PyPI): affected from 5.9.0; fixed in 9.5.1\n- lollms (PyPI): affected from 5.9.0; fixed in 9.5.1\n- lollms (PyPI): affected from 5.9.0; fixed in 9.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5443/ (Markdown: https://insights.sbomify.com/CVE-2024-5443/index.md)","id":"CVE-2024-5443","markdown":"https://insights.sbomify.com/CVE-2024-5443/index.md","name":"CVE-2024-5443","record":{"aliases":["GHSA-mvrm-fh8q-6wr2","PYSEC-2026-402"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM library","requires_auth":"none","summary":"Attackers can achieve remote code execution via path traversal in the mount_extension endpoint by manipulating directory parameters.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-29","name":"Path Traversal: '\\..\\filename'"}],"description":"CVE-2024-4320 describes a vulnerability in the parisneo/lollms software, specifically within the `ExtensionBuilder().build_extension()` function. The vulnerability arises from the `/mount_extension` endpoint, where a path traversal issue allows attackers to navigate beyond the intended directory structure. This is facilitated by the `data.category` and `data.folder` parameters accepting empty strings (`\"\"`), which, due to inadequate input sanitization, can lead to the construction of a `package_path` that points to the root directory. Consequently, if an attacker can create a `config.yaml` file in a controllable path, this path can be appended to the `extensions` list and trigger the execution of `__init__.py` in the current directory, leading to remote code execution. The vulnerability affects versions up to 5.9.0, and has been addressed in version 9.8.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Remote Code Execution via Path Traversal in parisneo/lollms","id":"CVE-2024-5443","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Bible Text \u003c= 0.2 - Contributor+ Stored XSS","id":"CVE-2024-5444"},"packages":[{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["5.9.0"],"last_affected":[],"package":"lollms","purl":null,"source":"GHSA-mvrm-fh8q-6wr2"},{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["5.9.0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"GHSA-mvrm-fh8q-6wr2"},{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["5.9.0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"PYSEC-2026-402"}],"prev":{"headline":"NextGEN Gallery \u003c 3.59.3 - Admin+ Stored XSS","id":"CVE-2024-5442"},"products":["parisneo/lollms"],"published":"2024-06-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["parisneo"]},"summary":"Attackers can achieve remote code execution via path traversal in the mount_extension endpoint by manipulating directory parameters.","url":"https://insights.sbomify.com/CVE-2024-5443/"}