# CVE-2024-5452: RCE via Property/Class Pollution in lightning-ai/pytorch-lightning

> Attackers can achieve remote code execution on self-hosted PyTorch Lightning applications by exploiting deserialization flaws in the default delta endpoint.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-cgwc-qvrx-rf7f, PYSEC-2026-385, PYSEC-2026-3974

## What is CVE-2024-5452?

CVE-2024-5452 is a critical unsafe deserialization vulnerability in lightning-ai/pytorch-lightning, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A remote code execution (RCE) vulnerability exists in the lightning-ai/pytorch-lightning library version 2.2.1 due to improper handling of deserialized user input and mismanagement of dunder attributes by the `deepdiff` library. The library uses `deepdiff.Delta` objects to modify application state based on frontend actions. However, it is possible to bypass the intended restrictions on modifying dunder attributes, allowing an attacker to construct a serialized delta that passes the deserializer whitelist and contains dunder attributes. When processed, this can be exploited to access other modules, classes, and instances, leading to arbitrary attribute write and total RCE on any self-hosted pytorch-lightning application in its default configuration, as the delta endpoint is enabled by default.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources), CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2024-5452?

4 open source packages ship an affected version, including lightning and pytorch-lightning. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightning` | PyPI | All versions | 2.3.3 |
| `lightning` | PyPI | All versions | 2.3.3 |
| `lightning` | PyPI | All versions | 2.3.3 |
| `pytorch-lightning` | PyPI | All versions | 2.3.3 |

Products: Lightningai Pytorch Lightning.

## How do I fix CVE-2024-5452?

Upgrade lightning to 2.3.3 or later.

## Is CVE-2024-5452 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5452 exists.

Public exploit code:

- https://github.com/skrkcb2/CVE-2024-5452 (github_poc): https://github.com/skrkcb2/CVE-2024-5452

## Other vulnerabilities in lightning-ai/pytorch-lightning

- [CVE-2026-44484](https://insights.sbomify.com/CVE-2026-44484/): Compromise of PyTorch Lightning PyPi Package Versions (critical 9.3)
- [CVE-2024-8019](https://insights.sbomify.com/CVE-2024-8019/): Arbitrary File Write/Overwrite in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2024-5980](https://insights.sbomify.com/CVE-2024-5980/): Arbitrary File Write via /v1/runs API endpoint in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2026-31221](https://insights.sbomify.com/CVE-2026-31221/): PyTorch Lightning load_from_checkpoint has an insecure checkpoint deserialization (high 8.8)
- [CVE-2026-58659](https://insights.sbomify.com/CVE-2026-58659/): PyTorch Lightning Arbitrary Code Execution via _instantiator Hyperparameter (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5452 and fix it if it is affected.

What it is: CVE-2024-5452 is a critical unsafe deserialization vulnerability in lightning-ai/pytorch-lightning, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5452 exists.

Affected packages and fixed versions:
- lightning (PyPI): affected all versions; fixed in 2.3.3
- lightning (PyPI): affected all versions; fixed in 2.3.3
- lightning (PyPI): affected all versions; fixed in 2.3.3
- pytorch-lightning (PyPI): affected all versions; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5452/ (Markdown: https://insights.sbomify.com/CVE-2024-5452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5452
- OSV: https://osv.dev/vulnerability/CVE-2024-5452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5452/
Summaries are generated and may contain mistakes; the official description above is the record.
