# CVE-2024-54662: Missing authorization in n/a

> Incorrect access control in Dante SOCKS server allows bypassing authentication when specific socksmethod configurations are used.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2024
- **Updated:** 18 Dec 2024
- **Also known as:** DEBIAN-CVE-2024-54662, GHSA-7w93-5823-j96v, UBUNTU-CVE-2024-54662, openSUSE-SU-2025:0030-1, openSUSE-SU-2025:15132-1

## What is CVE-2024-54662?

CVE-2024-54662 is a critical missing authorization vulnerability in n/a, published on 17 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dante 1.4.0 through 1.4.3 (fixed in 1.4.4) has incorrect access control for some sockd.conf configurations involving socksmethod.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-54662?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dante` | SUSE:Package Hub 15 SP6 | All versions | 1.4.4-bp156.4.3.1 |
| `dante` | openSUSE:Leap 15.6 | All versions | 1.4.4-bp156.4.3.1 |
| `dante` | openSUSE:Tumbleweed | All versions | 1.4.4-1.1 |

## How do I fix CVE-2024-54662?

Upgrade to a fixed version.

## Is CVE-2024-54662 being exploited?

There is no known exploitation of CVE-2024-54662 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54662 and fix it if it is affected.

What it is: CVE-2024-54662 is a critical missing authorization vulnerability in n/a, published on 17 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-54662 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54662/ (Markdown: https://insights.sbomify.com/CVE-2024-54662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54662
- OSV: https://osv.dev/vulnerability/CVE-2024-54662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54662/
Summaries are generated and may contain mistakes; the official description above is the record.
