CVE-2024-54677 Apache Tomcat: DoS in examples web application
Attackers can cause denial of service in Apache Tomcat by exploiting uncontrolled resource consumption in the examples web application, which is not enabled by default.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-54677?
CVE-2024-54677 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 17 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.
Weakness: CWE-400
Which versions are affected by CVE-2024-54677?
7 open source packages ship an affected version, including org.apache.tomcat:tomcat and tomcat. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.34 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.34 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.2 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.2 |
org.apache.tomcat:tomcat Maven | From 9.0.0.M1 | 9.0.98 |
org.apache.tomcat:tomcat Maven | From 9.0.0.M1 | 9.0.98 |
1 more packages
tomcat Bitnami | From 9.0.0 | 9.0.98, 10.1.34, 11.0.2 |
Products include Apache Tomcat, Netapp Bootstrap Os.
How do I fix CVE-2024-54677?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 10.1.34, 11.0.2 or 9.0.98.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-54677 being exploited?
There is no known exploitation of CVE-2024-54677 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2024-54677, DEBIAN-CVE-2024-54677, GHSA-653p-vg55-5652, UBUNTU-CVE-2024-54677.