# CVE-2024-54677: Apache Tomcat: DoS in examples web application

> Attackers can cause denial of service in Apache Tomcat by exploiting uncontrolled resource consumption in the examples web application, which is not enabled by default.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2024
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-tomcat-2024-54677, DEBIAN-CVE-2024-54677, GHSA-653p-vg55-5652, UBUNTU-CVE-2024-54677

## What is CVE-2024-54677?

CVE-2024-54677 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 17 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97.
The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions 
may also be affected.

Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-54677?

7 open source packages ship an affected version, including org.apache.tomcat:tomcat and tomcat. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.34 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.34 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.2 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.2 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0.M1 | 9.0.98 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0.M1 | 9.0.98 |
| `tomcat` | Bitnami | From 9.0.0 | 9.0.98, 10.1.34, 11.0.2 |

Products: Apache Tomcat, Netapp Bootstrap Os.

## How do I fix CVE-2024-54677?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 10.1.34, 11.0.2 or 9.0.98.

## Is CVE-2024-54677 being exploited?

There is no known exploitation of CVE-2024-54677 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-54677 and fix it if it is affected.

What it is: CVE-2024-54677 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 17 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-54677 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.34
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.34
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.2
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.2
- org.apache.tomcat:tomcat (Maven): affected from 9.0.0.M1; fixed in 9.0.98
- org.apache.tomcat:tomcat (Maven): affected from 9.0.0.M1; fixed in 9.0.98
- tomcat (Bitnami): affected from 9.0.0; fixed in 9.0.98, 10.1.34, 11.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-54677/ (Markdown: https://insights.sbomify.com/CVE-2024-54677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-54677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-54677
- OSV: https://osv.dev/vulnerability/CVE-2024-54677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-54677/
Summaries are generated and may contain mistakes; the official description above is the record.
