CVE-2024-54682 Zipbomb DoS via Missing Slack Import Validation

Medium 6.5 Published Updated

A team admin can cause a denial of service by uploading a zip bomb via the Slack import feature due to missing file size validation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-54682?

CVE-2024-54682 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 16 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.

Weakness: CWE-409

Which versions are affected by CVE-2024-54682?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 10.0.010.0.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.0.010.0.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.1.010.1.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.1.010.1.3
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.5
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.5
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.13
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.13
github.com/mattermost/mattermost-server GoFrom 9.5.0+incompatible9.5.13+incompatible, 9.11.5+incompatible, 10.0.3+incompatible, 10.1.3+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-54682?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.0.3, 10.1.3, 9.11.5 or 9.5.13.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-54682 being exploited?

There is no known exploitation of CVE-2024-54682 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-v647-h8jj-fw5r, GO-2024-3340.

Is CVE-2024-54682 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free