CVE-2024-5469 Uncontrolled Resource Consumption in GitLab

Low 3.1 Published Updated

An attacker can crash the GitLab Kubernetes Agent Server via crafted gRPC requests, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-5469?

CVE-2024-5469 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 14 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

DoS in KAS in GitLab CE/EE affecting all versions from 16.10.0 prior to 16.10.6 and 16.11.0 prior to 16.11.3 allows an attacker to crash KAS via crafted gRPC requests.

Weakness: CWE-754

Which versions are affected by CVE-2024-5469?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.10.016.10.6, 16.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2024-5469?

Upgrade gitlab to a fixed version for your release line: 16.10.6 or 16.11.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-5469 being exploited?

There is no known exploitation of CVE-2024-5469 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-5469, GHSA-4g7q-7v9w-3x8m, UBUNTU-CVE-2024-5469.

Is CVE-2024-5469 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free