CVE-2024-5470 Improper Access Control in GitLab
A Guest user with admin_push_rules permission can create project-level deploy tokens, potentially escalating privileges or accessing data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-5470?
CVE-2024-5470 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 17.0 prior to 17.0.4 and from 17.1 prior to 17.1.2 where a Guest user with `admin_push_rules` permission may have been able to create project-level deploy tokens.
Weakness: CWE-284
Which versions are affected by CVE-2024-5470?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.0.0 | 17.0.4, 17.1.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-5470?
Upgrade gitlab to a fixed version for your release line: 17.0.4 or 17.1.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-5470 being exploited?
There is no known exploitation of CVE-2024-5470 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-5470, GHSA-mhv3-28f9-6jvj, UBUNTU-CVE-2024-5470.