# CVE-2024-5520: Cross-Site Scripting stored in Alkacon OpenCMS

> Privileged users can inject malicious JavaScript via the title field in OpenCMS, enabling cross-site scripting attacks.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-vg6x-pchq-98mg

## What is CVE-2024-5520?

CVE-2024-5520 is a medium-severity cross-site scripting vulnerability in Alkacon OpenCMS, published on 30 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Two Cross-Site Scripting vulnerabilities have been discovered in Alkacon's OpenCMS affecting version 16, which could allow a user with sufficient privileges to create and modify web pages through the admin panel, can execute malicious JavaScript code, after inserting code in the “title” field.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-5520?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | From 16.0 | 17.0 |
| `org.opencms:opencms-core` | Maven | From 16.0 | 17.0 |

Products: Alkacon Opencms.

## How do I fix CVE-2024-5520?

Upgrade org.opencms:opencms-core to 17.0 or later.

## Is CVE-2024-5520 being exploited?

There is no known exploitation of CVE-2024-5520 in the wild and no public exploit code.

## Other vulnerabilities in Alkacon OpenCMS

- [CVE-2018-8811](https://insights.sbomify.com/CVE-2018-8811/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2019-11819](https://insights.sbomify.com/CVE-2019-11819/): Alkacon OpenCMS CSV Injection via New User module (high 7.8)
- [CVE-2005-4475](https://insights.sbomify.com/CVE-2005-4475/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2024-42699](https://insights.sbomify.com/CVE-2024-42699/): OpenCMS Cross-Site Scripting vulnerability (medium 6.5)
- [CVE-2021-3312](https://insights.sbomify.com/CVE-2021-3312/): XML External Entity Reference in org.opencms:opencms-core (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5520 and fix it if it is affected.

What it is: CVE-2024-5520 is a medium-severity cross-site scripting vulnerability in Alkacon OpenCMS, published on 30 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-5520 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected from 16.0; fixed in 17.0
- org.opencms:opencms-core (Maven): affected from 16.0; fixed in 17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5520/ (Markdown: https://insights.sbomify.com/CVE-2024-5520/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5520
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5520
- OSV: https://osv.dev/vulnerability/CVE-2024-5520

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5520/
Summaries are generated and may contain mistakes; the official description above is the record.
