# CVE-2024-55549: Use after free in libxslt

> A use-after-free vulnerability in libxslt allows attackers to potentially execute arbitrary code or cause a denial of service via crafted XSLT stylesheets.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2025
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2024-55549, ALSA-2025:4025, ALSA-2025:7410, AZL-58635, AZL-58680, BELL-CVE-2024-55549, BIT-java-2024-55549, BIT-java-min-2024-55549, BIT-jre-2024-55549, CLEANSTART-2026-ZL37756, CLSA-2025-1744623757, CLSA-2025-1745052086, CLSA-2025-1755617495, CLSA-2025-1756827524, CLSA-2026-1788260731, DEBIAN-CVE-2024-55549, GHSA-g8fv-r98j-937r, JLSEC-2026-582, MINI-c6m7-p84v-c6fw, RHSA-2025:3613, RHSA-2025:3614, RHSA-2025:4025, RHSA-2025:7410, RLSA-2025:7410, UBUNTU-CVE-2024-55549, USN-7357-1

## What is CVE-2024-55549?

CVE-2024-55549 is a high-severity use after free vulnerability in xmlsoft libxslt, published on 14 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

xsltGetInheritedNsList in libxslt before 1.1.43 has a use-after-free issue related to exclusion of result prefixes.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2024-55549?

3 open source packages ship an affected version, including java, java-min and jre. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `libxslt` | AlmaLinux:9 | All versions | 1.1.34-13.el9_6 |
| `libxslt` | AlmaLinux:9 | All versions | 1.1.34-9.el9_5.2 |
| `libxslt-devel` | AlmaLinux:9 | All versions | 1.1.34-13.el9_6 |
| `libxslt-devel` | AlmaLinux:9 | All versions | 1.1.34-9.el9_5.2 |
| `libxslt` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-13.el9_6 |
| `libxslt` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.2 |
| `libxslt-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-13.el9_6 |
| `libxslt-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.2 |
| `libxslt-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-13.el9_6 |
| `libxslt-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.2 |
| `libxslt-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-13.el9_6 |
| `libxslt-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.2 |
| `libxslt` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-11.el9_2 |
| `libxslt-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-11.el9_2 |
| `libxslt-debugsource` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-11.el9_2 |
| `libxslt-devel` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-11.el9_2 |
| `libxslt` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-13.el9_4 |
| `libxslt-debuginfo` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-13.el9_4 |
| `libxslt-debugsource` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-13.el9_4 |
| `libxslt-devel` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-13.el9_4 |
| `libxslt` | Rocky Linux:9 | All versions | 0:1.1.34-13.el9_6 |

Products: Xmlsoft Libxslt.

## How do I fix CVE-2024-55549?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.461.

## Is CVE-2024-55549 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55549 exists.

## Other vulnerabilities in xmlsoft libxslt

- [CVE-2025-24855](https://insights.sbomify.com/CVE-2025-24855/): Use after free in libxslt (high 7.8)
- [CVE-2008-2935](https://insights.sbomify.com/CVE-2008-2935/): Memory corruption in n/a (high 7.5)
- [CVE-2015-9019](https://insights.sbomify.com/CVE-2015-9019/): Weak cryptography in n/a (medium 5.3)
- [CVE-2013-4520](https://insights.sbomify.com/CVE-2013-4520/): Denial of service in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55549 and fix it if it is affected.

What it is: CVE-2024-55549 is a high-severity use after free vulnerability in xmlsoft libxslt, published on 14 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55549 exists.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55549/ (Markdown: https://insights.sbomify.com/CVE-2024-55549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55549
- OSV: https://osv.dev/vulnerability/CVE-2024-55549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55549/
Summaries are generated and may contain mistakes; the official description above is the record.
