CVE-2024-55553 Denial of service in n/a
An attacker can trigger continuous route re-validation in FRRouting, causing performance degradation and denial of service for routers using RPKI.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-55553?
CVE-2024-55553 is a high-severity denial of service vulnerability in n/a, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In FRRouting (FRR) before 10.3 from 6.0 onward, all routes are re-validated if the total size of an update received via RTR exceeds the internal socket's buffer size, default 4K on most OSes. An attacker can use this to trigger re-parsing of the RIB for FRR routers using RTR by causing more than this number of updates during an update interval (usually 30 minutes). Additionally, this effect regularly occurs organically. Furthermore, an attacker can use this to trigger route validation continuously. Given that routers with large full tables may need more than 30 minutes to fully re-validate the table, continuous issuance/withdrawal of large numbers of ROA may be used to impact the route handling performance of all FRR instances using RPKI globally. Additionally, the re-validation will cause heightened BMP traffic to ingestors. Fixed Versions: 10.0.3, 10.1.2, 10.2.1, >= 10.3.
Weakness: CWE-404
Which versions are affected by CVE-2024-55553?
Linux distribution packages (5)
frr SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 8.5.6-150500.4.33.1 |
frr SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 8.5.6-150500.4.33.1 |
frr SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 8.5.6-8.6.1 |
frr openSUSE:Leap 15.6 | All versions | 8.5.6-150500.4.33.1 |
frr openSUSE:Tumbleweed | All versions | 10.2.1-1.1 |
How do I fix CVE-2024-55553?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-55553 being exploited?
There is no known exploitation of CVE-2024-55553 in the wild and no public exploit code.
Sources
Also known as AZL-55066, AZL-55115, DEBIAN-CVE-2024-55553, DLA-4029-1, GHSA-hrrq-wpmq-47mf, SUSE-SU-2025:03274-1 and 4 more.