{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-55553 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-55553 is a high-severity denial of service vulnerability in n/a, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-55553 and fix it if it is affected.\n\nWhat it is: CVE-2024-55553 is a high-severity denial of service vulnerability in n/a, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-55553 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-55553/ (Markdown: https://insights.sbomify.com/CVE-2024-55553/index.md)","id":"CVE-2024-55553","markdown":"https://insights.sbomify.com/CVE-2024-55553/index.md","name":"CVE-2024-55553","record":{"aliases":["AZL-55066","AZL-55115","DEBIAN-CVE-2024-55553","DLA-4029-1","GHSA-hrrq-wpmq-47mf","SUSE-SU-2025:03274-1","SUSE-SU-2025:03297-1","SUSE-SU-2025:03453-1","UBUNTU-CVE-2024-55553","openSUSE-SU-2025:14632-1"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"FRRouting network software","requires_auth":"none","summary":"An attacker can trigger continuous route re-validation in FRRouting, causing performance degradation and denial of service for routers using RPKI.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"In FRRouting (FRR) before 10.3 from 6.0 onward, all routes are re-validated if the total size of an update received via RTR exceeds the internal socket's buffer size, default 4K on most OSes. An attacker can use this to trigger re-parsing of the RIB for FRR routers using RTR by causing more than this number of updates during an update interval (usually 30 minutes). Additionally, this effect regularly occurs organically. Furthermore, an attacker can use this to trigger route validation continuously. Given that routers with large full tables may need more than 30 minutes to fully re-validate the table, continuous issuance/withdrawal of large numbers of ROA may be used to impact the route handling performance of all FRR instances using RPKI globally. Additionally, the re-validation will cause heightened BMP traffic to ingestors. Fixed Versions: 10.0.3, 10.1.2, 10.2.1, \u003e= 10.3.","ecosystems":["SUSE:Linux Enterprise Module for Server Applications 15 SP6","SUSE:Linux Enterprise Module for Server Applications 15 SP7","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2024-55553","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":5,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-55554"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP6","fixed":["8.5.6-150500.4.33.1"],"introduced":["0"],"last_affected":[],"package":"frr","purl":"pkg:rpm/suse/frr\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP6","source":"SUSE-SU-2025:03453-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP7","fixed":["8.5.6-150500.4.33.1"],"introduced":["0"],"last_affected":[],"package":"frr","purl":"pkg:rpm/suse/frr\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP7","source":"SUSE-SU-2025:03453-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["8.5.6-8.6.1"],"introduced":["0"],"last_affected":[],"package":"frr","purl":"pkg:rpm/suse/frr\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2025:03297-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["8.5.6-150500.4.33.1"],"introduced":["0"],"last_affected":[],"package":"frr","purl":"pkg:rpm/opensuse/frr\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:03453-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["10.2.1-1.1"],"introduced":["0"],"last_affected":[],"package":"frr","purl":"pkg:rpm/opensuse/frr\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14632-1"}],"prev":{"headline":"Code injection in JDBC driver","id":"CVE-2024-55551"},"products":["n/a"],"published":"2025-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["n/a"]},"summary":"An attacker can trigger continuous route re-validation in FRRouting, causing performance degradation and denial of service for routers using RPKI.","url":"https://insights.sbomify.com/CVE-2024-55553/"}