# CVE-2024-55553: Denial of service in n/a

> An attacker can trigger continuous route re-validation in FRRouting, causing performance degradation and denial of service for routers using RPKI.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2025
- **Updated:** 23 Jan 2025
- **Also known as:** AZL-55066, AZL-55115, DEBIAN-CVE-2024-55553, DLA-4029-1, GHSA-hrrq-wpmq-47mf, SUSE-SU-2025:03274-1, SUSE-SU-2025:03297-1, SUSE-SU-2025:03453-1, UBUNTU-CVE-2024-55553, openSUSE-SU-2025:14632-1

## What is CVE-2024-55553?

CVE-2024-55553 is a high-severity denial of service vulnerability in n/a, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In FRRouting (FRR) before 10.3 from 6.0 onward, all routes are re-validated if the total size of an update received via RTR exceeds the internal socket's buffer size, default 4K on most OSes. An attacker can use this to trigger re-parsing of the RIB for FRR routers using RTR by causing more than this number of updates during an update interval (usually 30 minutes). Additionally, this effect regularly occurs organically. Furthermore, an attacker can use this to trigger route validation continuously. Given that routers with large full tables may need more than 30 minutes to fully re-validate the table, continuous issuance/withdrawal of large numbers of ROA may be used to impact the route handling performance of all FRR instances using RPKI globally. Additionally, the re-validation will cause heightened BMP traffic to ingestors. Fixed Versions: 10.0.3, 10.1.2, 10.2.1, >= 10.3.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2024-55553?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `frr` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 8.5.6-150500.4.33.1 |
| `frr` | SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 8.5.6-150500.4.33.1 |
| `frr` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 8.5.6-8.6.1 |
| `frr` | openSUSE:Leap 15.6 | All versions | 8.5.6-150500.4.33.1 |
| `frr` | openSUSE:Tumbleweed | All versions | 10.2.1-1.1 |

## How do I fix CVE-2024-55553?

Upgrade to a fixed version.

## Is CVE-2024-55553 being exploited?

There is no known exploitation of CVE-2024-55553 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55553 and fix it if it is affected.

What it is: CVE-2024-55553 is a high-severity denial of service vulnerability in n/a, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-55553 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55553/ (Markdown: https://insights.sbomify.com/CVE-2024-55553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55553
- OSV: https://osv.dev/vulnerability/CVE-2024-55553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55553/
Summaries are generated and may contain mistakes; the official description above is the record.
