CVE-2024-55565 Predictable results in nanoid generation when given non-integer values
Attackers can cause a denial of service in applications using nanoid by providing non-integer values that trigger an infinite loop.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-55565?
CVE-2024-55565 is a medium-severity denial of service vulnerability in n/a, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
nanoid (aka Nano ID) before 5.0.9 mishandles non-integer values. 3.3.8 is also a fixed version.
Weakness: CWE-835
Which versions are affected by CVE-2024-55565?
4 open source packages ship an affected version, including nanoid.
| Package | Affected | Fixed in |
|---|---|---|
nanoid npm | All versions | 3.3.8 |
nanoid npm | All versions | 3.3.8 |
nanoid npm | From 4.0.0 | 5.0.9 |
nanoid npm | From 4.0.0 | 5.0.9 |
How do I fix CVE-2024-55565?
Upgrade nanoid to a fixed version for your release line: 3.3.8 or 5.0.9.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-55565 being exploited?
There is no known exploitation of CVE-2024-55565 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1790707108, CLSA-2026-1790712460, DEBIAN-CVE-2024-55565, ECHO-14d3-52b7-d594, GHSA-mwcw-c2x4-8c55, MINI-3q8w-gc3h-c5rg and 4 more.