CVE-2024-55634 Drupal core - Moderately critical - Access bypass - SA-CORE-2024-004
Attackers can escalate privileges in Drupal core due to an access bypass vulnerability, requiring an upgrade to secure the system.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-55634?
CVE-2024-55634 is a high-severity vulnerability in Drupal Drupal, published on 9 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability in Drupal Core allows Privilege Escalation.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.
Which versions are affected by CVE-2024-55634?
20 open source packages ship an affected version, including drupal/core, drupal and drupal/core-recommended. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.3.0 | 10.3.9 |
drupal/core Packagist | From 10.3.0 | 10.3.9 |
drupal/core Packagist | From 11.0.0 | 11.0.8 |
drupal/core Packagist | From 11.0.0 | 11.0.8 |
drupal/core Packagist | From 8.0.0 | 10.2.11, 10.3.9, 11.0.8 |
drupal/core Packagist | From 8.0.0 | 10.2.11 |
14 more packages
drupal/core Packagist | From 8.0.0 | 10.2.11 |
drupal Bitnami | From 8.0.0 | 10.3.9, 11.0.8 |
drupal/core-recommended Packagist | From 10.3.0 | 10.3.9 |
drupal/core-recommended Packagist | From 10.3.0 | 10.3.9 |
drupal/core-recommended Packagist | From 11.0.0 | 11.0.8 |
drupal/core-recommended Packagist | From 11.0.0 | 11.0.8 |
drupal/core-recommended Packagist | From 8.0.0 | 10.2.11 |
drupal/core-recommended Packagist | From 8.0.0 | 10.2.11 |
drupal/drupal Packagist | From 10.3.0 | 10.3.9 |
drupal/drupal Packagist | From 10.3.0 | 10.3.9 |
drupal/drupal Packagist | From 11.0.0 | 11.0.8 |
drupal/drupal Packagist | From 11.0.0 | 11.0.8 |
drupal/drupal Packagist | From 8.0.0 | 10.2.11 |
drupal/drupal Packagist | From 8.0.0 | 10.2.11 |
Products include Drupal Drupal.
How do I fix CVE-2024-55634?
Upgrade drupal/core to a fixed version for your release line: 10.3.9, 11.0.8 or 10.2.11.
Is CVE-2024-55634 being exploited?
There is no known exploitation of CVE-2024-55634 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2024-55634, DRUPAL-CORE-2024-004, GHSA-7cwc-fjqm-8vh8, UBUNTU-CVE-2024-55634.