CVE-2024-55636 Drupal core - Less critical - Gadget chain - SA-CORE-2024-006
Drupal core contains a gadget chain enabling remote code execution if another vulnerability allows deserialization of untrusted data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-55636?
CVE-2024-55636 is a critical unsafe deserialization vulnerability in Drupal Drupal, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.
Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so called gadget chain presents no direct threat, but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.
Which versions are affected by CVE-2024-55636?
20 open source packages ship an affected version, including drupal/core, drupal and drupal/core-recommended. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.3.0 | 10.3.9 |
drupal/core Packagist | From 10.3.0 | 10.3.9 |
drupal/core Packagist | From 11.0.0 | 11.0.8 |
drupal/core Packagist | From 11.0.0 | 11.0.8 |
drupal/core Packagist | From 8.0.0 | 10.2.11, 10.3.9, 11.0.8 |
drupal/core Packagist | From 8.8.0 | 10.2.11 |
14 more packages
drupal/core Packagist | From 8.8.0 | 10.2.11 |
drupal Bitnami | From 8.0.0 | 10.3.9, 11.0.8 |
drupal/core-recommended Packagist | From 10.3.0 | 10.3.9 |
drupal/core-recommended Packagist | From 10.3.0 | 10.3.9 |
drupal/core-recommended Packagist | From 11.0.0 | 11.0.8 |
drupal/core-recommended Packagist | From 11.0.0 | 11.0.8 |
drupal/core-recommended Packagist | From 8.8.0 | 10.2.11 |
drupal/core-recommended Packagist | From 8.8.0 | 10.2.11 |
drupal/drupal Packagist | From 10.3.0 | 10.3.9 |
drupal/drupal Packagist | From 10.3.0 | 10.3.9 |
drupal/drupal Packagist | From 11.0.0 | 11.0.8 |
drupal/drupal Packagist | From 11.0.0 | 11.0.8 |
drupal/drupal Packagist | From 8.8.0 | 10.2.11 |
drupal/drupal Packagist | From 8.8.0 | 10.2.11 |
Products include Drupal Drupal.
How do I fix CVE-2024-55636?
Upgrade drupal/core to a fixed version for your release line: 10.3.9, 11.0.8 or 10.2.11.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2024-55636 being exploited?
There is no known exploitation of CVE-2024-55636 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2024-55636, DRUPAL-CORE-2024-006, GHSA-938f-5r4f-h65v, UBUNTU-CVE-2024-55636.