CVE-2024-55637 Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007

Critical 9.8 Published Updated

Drupal core contains a gadget chain enabling remote code execution if another vulnerability allows deserialization of untrusted data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-55637?

CVE-2024-55637 is a critical unsafe deserialization vulnerability in Drupal Drupal, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so-called gadget chain presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.

Weakness: CWE-502, CWE-915

Which versions are affected by CVE-2024-55637?

20 open source packages ship an affected version, including drupal/core, drupal and drupal/core-recommended. It affects 1 product.

PackageAffectedFixed in
drupal/core PackagistFrom 10.3.010.3.9
drupal/core PackagistFrom 10.3.010.3.9
drupal/core PackagistFrom 11.0.011.0.8
drupal/core PackagistFrom 11.0.011.0.8
drupal/core PackagistFrom 8.0.010.2.11, 10.3.9, 11.0.8
drupal/core PackagistFrom 8.8.010.2.11
14 more packages
drupal/core PackagistFrom 8.8.010.2.11
drupal BitnamiFrom 8.0.010.3.9, 11.0.8
drupal/core-recommended PackagistFrom 10.3.010.3.9
drupal/core-recommended PackagistFrom 10.3.010.3.9
drupal/core-recommended PackagistFrom 11.0.011.0.8
drupal/core-recommended PackagistFrom 11.0.011.0.8
drupal/core-recommended PackagistFrom 8.8.010.2.11
drupal/core-recommended PackagistFrom 8.8.010.2.11
drupal/drupal PackagistFrom 10.3.010.3.9
drupal/drupal PackagistFrom 10.3.010.3.9
drupal/drupal PackagistFrom 11.0.011.0.8
drupal/drupal PackagistFrom 11.0.011.0.8
drupal/drupal PackagistFrom 8.8.010.2.11
drupal/drupal PackagistFrom 8.8.010.2.11

Products include Drupal Drupal.

How do I fix CVE-2024-55637?

Upgrade drupal/core to a fixed version for your release line: 10.3.9, 11.0.8 or 10.2.11.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2024-55637 being exploited?

There is no known exploitation of CVE-2024-55637 in the wild and no public exploit code.

All Drupal Drupal vulnerabilities

Sources

Also known as BIT-drupal-2024-55637, DRUPAL-CORE-2024-007, GHSA-w6rx-9g2x-mg5g, UBUNTU-CVE-2024-55637.

Is CVE-2024-55637 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free