# CVE-2024-55637: Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007

> Drupal core contains a gadget chain enabling remote code execution if another vulnerability allows deserialization of untrusted data.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2024
- **Updated:** 16 Dec 2024
- **Also known as:** BIT-drupal-2024-55637, DRUPAL-CORE-2024-007, GHSA-w6rx-9g2x-mg5g, UBUNTU-CVE-2024-55637

## What is CVE-2024-55637?

CVE-2024-55637 is a critical unsafe deserialization vulnerability in Drupal Drupal, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so-called gadget chain presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2024-55637?

20 open source packages ship an affected version, including drupal/core, drupal and drupal/core-recommended. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 10.3.0 | 10.3.9 |
| `drupal/core` | Packagist | From 10.3.0 | 10.3.9 |
| `drupal/core` | Packagist | From 11.0.0 | 11.0.8 |
| `drupal/core` | Packagist | From 11.0.0 | 11.0.8 |
| `drupal/core` | Packagist | From 8.0.0 | 10.2.11, 10.3.9, 11.0.8 |
| `drupal/core` | Packagist | From 8.8.0 | 10.2.11 |
| `drupal/core` | Packagist | From 8.8.0 | 10.2.11 |
| `drupal` | Bitnami | From 8.0.0 | 10.3.9, 11.0.8 |
| `drupal/core-recommended` | Packagist | From 10.3.0 | 10.3.9 |
| `drupal/core-recommended` | Packagist | From 10.3.0 | 10.3.9 |
| `drupal/core-recommended` | Packagist | From 11.0.0 | 11.0.8 |
| `drupal/core-recommended` | Packagist | From 11.0.0 | 11.0.8 |
| `drupal/core-recommended` | Packagist | From 8.8.0 | 10.2.11 |
| `drupal/core-recommended` | Packagist | From 8.8.0 | 10.2.11 |
| `drupal/drupal` | Packagist | From 10.3.0 | 10.3.9 |
| `drupal/drupal` | Packagist | From 10.3.0 | 10.3.9 |
| `drupal/drupal` | Packagist | From 11.0.0 | 11.0.8 |
| `drupal/drupal` | Packagist | From 11.0.0 | 11.0.8 |
| `drupal/drupal` | Packagist | From 8.8.0 | 10.2.11 |
| `drupal/drupal` | Packagist | From 8.8.0 | 10.2.11 |

Products: Drupal Drupal.

## How do I fix CVE-2024-55637?

Upgrade drupal/core to a fixed version for your release line: 10.3.9, 11.0.8 or 10.2.11.

## Is CVE-2024-55637 being exploited?

There is no known exploitation of CVE-2024-55637 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55637 and fix it if it is affected.

What it is: CVE-2024-55637 is a critical unsafe deserialization vulnerability in Drupal Drupal, published on 9 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-55637 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 10.3.0; fixed in 10.3.9
- drupal/core (Packagist): affected from 10.3.0; fixed in 10.3.9
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.0.8
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.0.8
- drupal/core (Packagist): affected from 8.0.0; fixed in 10.2.11, 10.3.9, 11.0.8
- drupal/core (Packagist): affected from 8.8.0; fixed in 10.2.11
- drupal/core (Packagist): affected from 8.8.0; fixed in 10.2.11
- drupal (Bitnami): affected from 8.0.0; fixed in 10.3.9, 11.0.8
- drupal/core-recommended (Packagist): affected from 10.3.0; fixed in 10.3.9
- drupal/core-recommended (Packagist): affected from 10.3.0; fixed in 10.3.9
- drupal/core-recommended (Packagist): affected from 11.0.0; fixed in 11.0.8
- drupal/core-recommended (Packagist): affected from 11.0.0; fixed in 11.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55637/ (Markdown: https://insights.sbomify.com/CVE-2024-55637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55637
- OSV: https://osv.dev/vulnerability/CVE-2024-55637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55637/
Summaries are generated and may contain mistakes; the official description above is the record.
