CVE-2024-5566 Improper Privilege Management allows for access to unauthorized repository content during migration
Attackers can migrate private repositories without proper token scopes, accessing unauthorized content in GitHub Enterprise Server.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-5566?
CVE-2024-5566 is a medium-severity vulnerability in Github Enterprise Server, published on 16 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal Access Token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17.
Weakness: CWE-269
Which versions are affected by CVE-2024-5566?
It affects 1 product.
Products include Github Enterprise Server.
How do I fix CVE-2024-5566?
No fix has been published for CVE-2024-5566 yet. Limit exposure of the affected software until one is available.
Is CVE-2024-5566 being exploited?
There is no known exploitation of CVE-2024-5566 in the wild and no public exploit code.
Other vulnerabilities in Github Enterprise Server
- CVE-2024-4985 Auth bypass in Enterprise Server
- CVE-2022-23739 Missing authorization in GitHub Enterprise Server
- CVE-2022-46255 Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE
- CVE-2021-22869 Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group
- CVE-2024-9487 Auth bypass in Enterprise Server
Sources
Also known as GHSA-5m5g-r44m-96r4.